Posts by goppi

    Die WebKit Engine muss einfach nur in den Verbindungsoptionen aktiviert werden:


    Dann crashed by mir die Anwendung



    Interressanter Weise passiert dies nicht wenn RDP-Manager über den Installer
    installiert wurde. Kopiert man hingegen lediglich die Dateien aus dem
    Zip-Archiv in einen Order dann crashed die Anwendnung.


    Was mach der Installer, damit das nicht passiert?


    Vielen Dank und Grüße


    goppi.

    Grundsätzlich ist Sqlite kein Problem das stimmt. Der RDP-Manager hat allerdings kein locking, da Multi User Zugriffe nie vorgsehen waren.
    Bei gleichzeitigem schreiben kracht es daher vermutlich ab und an...

    Das glaub ich eingetlich nicht.
    Parallele Lesezugriffe kommen sich nicht in die Quere.
    Parallele Schreibzugriffe werden durch Locking des gesamten DB-Files auf Ebene des Filesystems serialisiert.
    Wenn das zu lange dauert sollte allenfalls ein SQLITE_BUSY zurückgegeben werden, aber die DB bleibt konsistent.


    Naja habe das Probelm jetzt umgangen indem ich RDPManager für Administratoren mit einem RunAs "Dummy User" aufrufe. Dann klappt das auch wieder mehrfach als Benutzer "Administrator". Schon seltsam warum das nur beim Admin passiert.


    Für diejenigen meiner Kunden, die nicht nur einen Admin sonder eine IT-Abteilung haben ist eine gemeinsame Datenbasis des Programms schon wichtig. Habe schon überlegt die Datenbank einfach maschinell zu synchen aber das ist natürlich aufwändig, ausßerdem hab ich keine Möglichkeit gefunden beim Start ein DB-Verzeichnis anzugeben.


    Gruß


    goppi.

    Hmm.


    Wir haben hier bisher kein Problem festellen können.
    Wie gesagt nur wenn das zweimal der Administrator versucht.
    Das die Systemeinstellungen des Benutzers der die Anwendung zuletzt beendet gelten stört nicht.


    Multiuser mit SQLite muß nicht zwangsläufig ein Problem sein:


    http://www.sqlite.org/faq.html#q5


    Gibt es denn schon Neuigkeiten bzgl. des MSSQL Handlers?


    Gruß


    goppi.

    Hallo.


    Weis nicht ob das Verhalten "by Design" oder ein Fehler ist:


    Die "system.ini" wird augenscheinlich im Startverzeichnis und damit nicht
    unbedingt im Anwendungsverzeichnis gesucht.


    Gruß


    goppi.

    Ja genau - das funktioniert bisher ganz gut, der MSSQL Hanlder ist ja noch in Arbeit.


    Das Problem ist wirklich der "Administrator" Anwender (evtl. UAC Problem?)
    Zweimal als gleicher Anwender mit Administrator Rechten geht.


    Gruß


    Fehlermeldung:


    Hallo.


    Bisher haben wir die Anwendung erfolgreich auf einem Terminalserver auch mehrfach starten können.


    Jetzt haben wir einen Kunden bei dem mehrere Benutzer gleichzeitig als Benutzer "Administrator" an einem Terminalserver (Management-Server) angemeldet sind. Dort kracht es sobald ein zweiter Benutzer die Anwendung startet und das Passwort eingegeben hat. Interssanter Weise können auch dort zwei normale Benutzer die Anwendung parallel starten, auch wenn sie beide mit dem gleichen Benutzerkonto angemeldet sind; nur eben nicht als Benutzer "Administrator". Habe das Ganze noch einmal in einer unabhängigen Testumgebung nachgestellt - gleiches Ergebnis.


    Irgend eine Idee woran das liegen könnte und wie mas das zum Laufen bringt?


    Vielen Dank.


    Gruß


    goppi.

    Hallo,


    mit der Version 4.8.1 wird bei deaktivierter News Abfrage auch keine Online Verbindung mehr aufgebaut.
    Das "Was ist neu" Fenster sollte jetzt auch korrekt verarbeitet werden.


    Viele Grüße
    Pierre

    Jo das schaut jetzt gut aus.


    Danke
    goppi.

    Zum Fehler wegen der "Was ist neu in dieser Version" Seite noch eine Frage:
    Wurde die Seite denn einmalig korrekt angezeigt oder bereits beim Abrufen von einer Firewall o.ä. geblockt?
    Dann versuche ich mal das nachzustellen und zu beheben.

    Es ist keine Firewall aktiv.


    Die Seite wird immer wieder korrekt angezeigt, allerdings erfolgt die Anzeige bei jedem Start erneut.
    Kann es sein, dass die Einstellung "WhatsNewNewsVersion" in der Datenbank nicht aktualisiert wird,
    wenn die Option "Online auf Nachrichten prüfen" deaktiviert ist.


    Nachdem ich die Option "Online auf Nachrichten prüfen" aktiert habe, wurde "WhatsNewNewsVersion"
    in der Datenbank gesetzt und beim nächsten Start unterblieb die Anzeige.


    Gruß
    goppi.

    Hallo.


    Seit es den Splash Screen gibt ist das Fenster zur Eingabe des Kennwortes danach leider inaktiv.
    Deshalb muß man immer noch mal zur Maus greifen um es zu aktivieren und dann wieder zur Tastatur
    um das Kennwort einzutippen.


    Wäre schön, wenn das Kennwortfenster nach schließen des Splash Screens aktiv dargestellt werden würde.


    Gruß


    goppi.

    Hallo,


    ich habe die neue Version 4.8 über die Version 4.7 kopiert (zip Archiv).


    Leider wird bei jedem Aufruf immer wieder die Seite "Was ist neu in dieser Version" geladen, obwohl in
    den Einstellungen "Online auf Nachrichten prüfen" deaktiviert ist.


    Trotz dieser Einstellung wurde auch in der Vorgängerversion schon bei jedem
    Neustart in der Statuszeile die Meldung: "Keine Nachrichten gefunden - Der Remote Server hat einen Fehler (404) zurückgegeben angezeigt.
    Wird diese Einstellung evtl. ignoriert?


    In der SQL Datenbank steht in der AppSettings Tabelle "WhatsNewNewsVersion" auch immer noch "4.7.0.64".
    Ändert man diesen manuell auf "4.8.0.54" kommt die Seite "Neu in dieser Version" nicht mehr, der Serverfehler erscheint aber
    nach wie vor.


    Es wäre schön, wenn man alle Funktionen die selbständig Verbindung mit dem Internet aufbauen vollständig deaktivieren könnte.
    Es gibt Unternehmen mit Compliance Richtlinien, die den Einsatz dieser wirklich schicken Software ansonsten leider verhindern würden.


    Vielen Dank.


    Gruß
    goppi.