Posts by goppi

    Es ist schade, dass man die IE Version nur auf Programmebene festlegen kann und nicht auf Verbindungsebene.


    Ich weiß auch nicht ob dies bei dem Anwendungsdesign möglich wäre.


    Da ja Microsoft nur noch IE 11 supportet, es aber viele insbesondere ältere Devices mit integriertem Webinterface gibt die mit dem IE11 nix anfangen können, wäre das hilfreich.

    Ohje, da habe ich nicht gründlich genug gesucht.


    Da ich unter dem Menü "Datei" bereits den Punkt "Datenbank prüfen" gesehen hatte, habe ich eine verwandte Funktion dort vermutet.


    Vielen Dank.

    Hallo.


    Ich habe etliche Order und Verbindungen gelöscht, trotzdem wurde die Datenbank nicht kleiner - erstmal logisch.


    Also mit sqlite3.exe auf der Datenbank ein VACUUM gemacht - trotzdem nicht kleiner.


    Dann mir einem Drittanbieterwerkzeug in die Datenbank gesehen und festgestellt, dass diese Datensätze nicht gelöscht wurden, sondern vom Programm in einer Spalte "Deleted" lediglich gekennzeichnet wurden.


    Gibt es eine supportete Möglichkeit diese Datensätze dauerhaft zu löschen daamit die Dantenbank wieder kleiner wird? Möchte dies ungern außerhalb der Anwendung machen um die Datenintegrität nicht zu gefährden.


    Danke.

    Hallo,


    wir setzen die x86 Version ein.


    Ich habe heute ziemlich intensiv mit der Anwendung gearbeitet und glaube mittlerweile, dass es nicht direkt an RDP liegt. Ähnliches passiert auch mit Web Verbindungen. Es ist eigentlich immer das gleiche Schema. Die Probleme beginnen, sobald man Verbindungen anfängt zu schließen. Wenn man dann wieder neue Verbindungen öffnet, passiert bei den ersten Versuchen nichts und dann stürzt die Anwendung ab. Hatte das heute ca. 5 mal.


    Da es auch nicht unbedingt häufiger auftritt, wenn man viele Verbindungen öffnet, glaube ich mittlerweise auch nicht mehr, dass es unbending ein Problem von Speichermagenl ist. Habe das auch in einer VM vergleichsweise getestet. Ob die nun 1 GB oder 3 GB hat verhält sich eigentlich gleich.


    Gruß


    goppi.

    Hallo.


    Ich habe folgendes Problem.


    Wenn ich mehrere RDP Verbindungen geöffnet habe (5 bis 7 Stück), dann kann ich nach dem Schließen von einer bzw. manchaml mehrerer RDP Verbindungen keine neuen RDP Verbindungen mehr öffnen. Es passiert dann einfach nichts. Wenn ich das erneute Öffnen dann drei bis vier mal wiederhole stürzt die Anwendung meistens ab.


    Wird evtl. beim schließen einer RDP Verbindung der Speicher nicht vollständig wieder freigegeben oder was könnte das noch sein?


    Gruß


    goppi.

    Ok das heißt das Programm verhält sich jetzt so wie man es erwarten würde ;)

    Exakt.


    Wenn man Workarounds zur Umgehung von Fehlern verwendet, muss man halt damit rechnen, dass wenn das Problem gefixed ist, der Workaround selbst zum Problem wird.


    Gruß


    goppi.

    Ist vermutlich ein alter Fehler der gefixed wurde, was sich bei mit aber unvorhersehbar ausgewirkt hat.


    Unter "Einstellungen" für "Externe Anwendungen" trägt man einen Programmaufruf ein.
    Wenn der hier erzeugte Prozess beendet wird, dann wird jetzt der Eintrag unter "Externe Anwendungen" "Start beim beenden der Verbindung" ausgeführt. Das war vorher nicht der Fall.


    Deshalb wurde bei mir jetzt nach ausführen des Programms zum Herstellen der Verbindung gleich wieder das Programm beim Beenden der Verbindung ausgeführt, weil ersteres (CMD /C) keinen Prozess erzeugt der dauerhaft läuft.


    Gruß


    goppi.

    Hab das Problem gefunden.


    Neuerdings wird offensichtlich, nachem ein externes Programm zum Verbindungsaufbau beendet wurde, das Skript, welches unter "beim Beenden ausführen" eingetragen ist, ausgeführt. Das war Früher nicht der Fall.


    Habe den Aufruf von "CMD.EXE /C NET USE......." in "CMD.EXE /K NET USE........." geändert und dann geht es, da der Prozess nach Ausführen des Befehls nicht beendet wird.


    Gruß


    goppi.

    Hallo.


    Hat sich der Kontext in dem externe Programme aufgerufen werden geändert.
    z.B. das Mappen eines Laufwerkes funktioniert, das Laufwerk ist in der Benutzersitzung aber nicht verfügbar.


    Funktioniert hat dies noch einwandfrei mit 4.9.1.
    Mit 4.9.3 und 4.9.4 leider nicht mehr.


    Danke.


    Gruß
    goppi.

    Das Problem einer kostenpflichtigen Version ist, dass man sich damit dann in direkte Konkurrenz zu den bereits bestehenden komerziellen Produkte begibt und da gibt es welche mit doch erheblichem Funktionsumfang. Das kann also auch nach hinten losgehen.


    Gruß


    goppi


    nach einem halben Jahr musste ich leider feststellen, das die
    entwicklung einer Serverbasierten Version, für einen einzelnen
    Entwickler ein zu großes Projekt darstellt.


    Wirklich schade aber nachvollziehbar.


    Das Problem ist immer wenn man das bei einem Projekt von der Architektur nicht von Anfang an vorgesehen hat und versuchen muß hinterher zu implementieren. Bei einer vollständigen Kapselung der Datenzugriffe ist es normalerweise nicht so schwierig die Persistenz der Objekte auf andere Speicherarten auszuweiten (andere Datenbanken, oder XML oder whatever).


    Gruß

    Na wenn ich von der Homepage "http://www.cinspiration.de/" den Menüpunkt Projektverwaltung
    auswähle, dann kommt die Frage nach Benutzername + Passwort.


    Gruß

    [minipoll='6a1688b7fbb053993712a4bf5fd43c45']Feature umsetzen[/minipoll]


    Wäre schön im Datei-Menü einen Menüpunkt zu haben
    "Datenbank komprimieren" der den nicht belegten Speicher
    der Datenbank freigibt um eine einmal durch Logeinträge
    aufgeblasene Datenbank wirder klein zu kriegen.


    Gruß


    goppi

    Hi,


    ich glaube ich hatte in der Version vom 25. beim kompilieren einen Schalter falsch gesetzt...
    Bitte probier bei Gelegenheit die Version im Anhang noch einmal.


    Viele Grüße


    Diese Version funktioniert.
    Das diese Version beim start den Mutex in einem Dialog anzeigt ist vermutlich noch eine Debug-Geschichte.


    Gruß


    goppi.