Skript vor Verbindungsaufbau ausführen

  • <p>Hallo zusammen,</p>
    <p>Ich möchte gerne die Funktionalität nutzen, Anwendungen vor dem Start einer RDP-Verbindung auszuführen.<br>Konkret geht es darum, Nicht-Windows-VPNS aufzubauen, ohne da den VPN-Client via GUI starten zu müssen und das Passwort einzugeben.</p>
    <p>Hier habe ich bereits ein PowerShellskript (kann ich auch als Batchskript machen) vorbereitet - als Beispiel hier mit Dell SonicWall NetExtender - in Zukunft mag ich ähnliches auch mit OpenVPN, Sophos VPN, FortiClient und Shrew machen.</p>
    <p><span style="font-family: Tahoma,Geneva,sans-serif"><em>Set-location C:\Program Files (x86)\SonicWALL\SSL-VPN\NetExtender</em><br><em>necli.exe -server remote.*****com -user-name ******* -password ******-domain-name ********</em><br><em>start-sleep 10</em><br><em></em></span></p>
    <p>Mein Problem ist nun, dass ich zwar sagen kann, führe PowerShell als Anwendung vorher aus, aber ich finde keine Möglichkeit zu sagen, welche Datei (.ps1) die PowerShell ausführen soll.</p>
    <p>Daher meine Frage:</p>
    <p>Wie kann ich den RDP Manager so konfigurieren, dass er mir vor Starten der RDP-Verbindung die CMD/PowerShell öffnet (am besten im Hintergrund) und ein per Pfad hinterlegtes Skript ausführt?</p>
    <p>Danke für die Hilfe.</p>
    <p>Alex</p>
    <p>P.S: Das Programm ist auf jeden Fall Gold wert, kann ich nur immer wieder betonen. Weiter so.<br> <img src="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44d.png" class="smiley" alt=":thumbsup:" height="23" srcset="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44d@2x.png 2x"></p>
    <p><span style="font-family: Tahoma,Geneva,sans-serif"></span></p>
    <p><span style="font-family: Tahoma,Geneva,sans-serif"></span></p>

  • <p>Hallo Alex,</p>
    <p>die Script Datei kannst du dann einfach als Parameter angeben. Die powershell sollte (dazu unten mehr) diese dann einfach ausführen.<br>Wichtig ist hierbei noch das du den Haken bei "Warte auf ende" und eine Zeit in Sekunden bei "Maximale Wartezeit" angibst. Die Verbindung soll ja vermutlich erst gestartet werden wenn das VPN steht <img src="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f609.png" class="smiley" alt=";)" height="23" srcset="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f609@2x.png 2x"> <br><woltlab-metacode data-name="attach" data-attributes="WyIxNTMiXQ=="></woltlab-metacode></p>
    <p>Nachdem ich alles wie auf dem Screenshot konfiguriert hatte, hab ich naiv wie ich bin schon gedacht das wäre es gewesen. Allerdings führt der Aufruf (zumindest auf meinem Rechner) wie oben konfiguriert ins leere <img src="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44e.png" class="smiley" alt=":thumbdown:" height="23" srcset="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44e@2x.png 2x"> <br>Nach langem probieren und einstellen ist mir dann aufgefallen das die "normale" Powershell execution policy die man als Administrator setzen kann, für die durch den RDP-Manager gestartete powershell nicht greift.<br>Daher muss eine der beiden Vorraussetzungen gegeben sein damit das wie oben beschrieben klappt:</p>
    <ul>
    <li>Das auszuführende Script muss mit einem vertrauenswürdigen Zertifikat digital signiert sein.</li>
    <li>Die Execution Policy muss in der Registry des aktuellen Benutzers auf Unrestricted gestellt werden.<br><ul>
    <li>"HKEY_CURRENT_USER\Software\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell" öffnen</li>
    <li>Eine neue Zeichenfolge (REG_SZ) "ExecutionPolicy" mit dem Wert "Unrestricted" anlegen.<br><woltlab-metacode data-name="attach" data-attributes="WyIxNTQiXQ=="></woltlab-metacode>
    </li>
    </ul>
    </li>
    </ul>
    <p></p>
    <p>Mit diesen Einstellungen und unter einer der beiden Vorraussetzungen sollte das dann auch bei dir funktionieren <img src="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44d.png" class="smiley" alt=":thumbup:" height="23" srcset="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f44d@2x.png 2x"></p>
    <p>Viele Grüße</p>

  • <p>Hallo Pierre,</p>
    <p>vielen Dank für die fundierte Hilfe.<br>Mein Hauptfehler war, dass ich verzockt habe, dass ich analog der Einstellungsdeklarationen auch bei den externen Anwendungen diese erstmal global vorkonfigurieren muss, bevor ich sie konkreten Verbindungen zuordnen kann. Das ist mir leider schon paar mal passiert <img src="https://forum.cinspiration.de/wcf/images/smilies/wacko.png" class="smiley" alt=":wacko:" height="17"></p>
    <p>Ich guck mir das am Freitag auf der Arbeit gleich mal an.<br>Das mit der Ausführungsrichtlinie ist kein Ding, die ist bei mir auf dem Client sowieso immer deaktiviert via</p>
    <p><span style="font-family: Lucida Sans Unicode,Lucida Grande,sans-serif"><span style="color: #0000FF">Set-Executionpolicy </span><span style="color: #800080">bypass</span></span><br>(das ändert letztlich auch nur den Registrykey - ist aber die politisch korrekte Vorgehensweise :D)</p>
    <p>Bei automatisierten Prozessen auf Servern oder im Hintergrund sollte man evtl die Execution policy nicht dauerhaft ausschalten, sondern individuell für den Befehl deaktivieren (so mach ich das etwa für einige zeitgesteuerte Skripte)</p>
    <p><span style="font-family: Lucida Sans Unicode,Lucida Grande,sans-serif">
    </span></p>
    <p><span style="font-family: Lucida Sans Unicode,Lucida Grande,sans-serif"><span style="color: #0000FF">powershell.exe</span> <strong><u><span style="color: #B22222">-nologo -noprofile -noexit -executionpolicy</span> <span style="color: #800080">bypass</span></u></strong> <span style="color: #B22222">-file</span> <span style="color: #800080">meinscript.ps1</span></span></p>
    <p>dann gibt PowerShell ganz schnell Ruhe mit irgendwelchen Skriptausführungsverboten<br> <img src="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f606.png" class="smiley" alt=":D" height="23" srcset="https://forum.cinspiration.de/wcf/images/smilies/emojione/1f606@2x.png 2x"></p>
    <p>Ich melde mich zurück, wenn ich getestet habe.</p>
    <p>Thanks</p>
    <p>Alex</p>

  • Hallo zusammen


    ganz vergessen, zurück zu schreiben:

    Habe das Ganze erfolgreich zum Laufen gekriegt. Dummerweise brauch ich bei dem betreffenden Kunden nun keine VPN mehr ( :D)


    Werde die Technik aber in Zukunft für andere RDP Managereinträge nutzen.


    Danke nochmal.

    Den Thread könnte man schließen ;)